quic-go's path validation mechanism can cause denial of service
Default status is the baseline for the product, each version can override it (e.g. patched versions marked unaffected).
| Vendor | Product | Default status | Versions | |||||||||||||||
|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|
| quic-go | quic-go | affected |
|
Configuration 1 [-]
|
| Package | CPE | Advisory | Released Date |
|---|---|---|---|
| Red Hat Ansible Automation Platform 2.4 for RHEL 8 | |||
| receptor-0:1.4.4-1.el8ap | cpe:/a:redhat:ansible_automation_platform:2.4::el8 | RHSA-2024:0855 | 2024-02-19T00:00:00Z |
| Red Hat Ansible Automation Platform 2.4 for RHEL 9 | |||
| receptor-0:1.4.4-1.el9ap | cpe:/a:redhat:ansible_automation_platform:2.4::el9 | RHSA-2024:0855 | 2024-02-19T00:00:00Z |
No data available yet.
| Source | ID | Title |
|---|---|---|
EUVD |
EUVD-2024-0394 | quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go. An attacker can cause its peer to run out of memory sending a large number of PATH_CHALLENGE frames. The receiver is supposed to respond to each PATH_CHALLENGE frame with a PATH_RESPONSE frame. The attacker can prevent the receiver from sending out (the vast majority of) these PATH_RESPONSE frames by collapsing the peers congestion window (by selectively acknowledging received packets) and by manipulating the peer's RTT estimate. This vulnerability has been patched in versions 0.37.7, 0.38.2 and 0.39.4. |
Github GHSA |
GHSA-ppxx-5m9h-6vxf | quic-go's path validation mechanism can be exploited to cause denial of service |
No CVSS v4.0
No CVSS v3.0
No CVSS v2
This CVE is not in the KEV list.
Exploit prediction score: 1.2% (1.204% probability within 30 days)
| Type | Values Removed | Values Added |
|---|---|---|
| Metrics |
ssvc
|