Search vulnerabilities

Results 222

Export CSV
CVE-2025-40777

A possible assertion failure when 'stale-answer-client-timeout' is set to '0'

If a `named` caching resolver is configured with `serve-stale-enable` `yes`, and with `stale-answer-client-timeout` set to `0` (the only allowable value other than `disabled`), and if the resolver, in the process of resolving a query, encounters a CNAME chain involving a specific combination of cached or authoritative records, the daemon will abort with an assertion failure. This issue affects BIND 9 versions 9.20.0 through 9.20.10, 9.21.0 through 9.21.9, and 9.20.9-S1 through 9.20.10-S1.

CVSS 3.1 · 7.5 High EPSS 1.0% KEV · Not listed
Vendors
Isc
Products
CVE-2025-8677

Resource exhaustion via malformed DNSKEY handling

Querying for records within a specially crafted zone containing certain malformed DNSKEY records can lead to CPU exhaustion. This issue affects BIND 9 versions 9.18.0 through 9.18.39, 9.20.0 through 9.20.13, 9.21.0 through 9.21.12, 9.18.11-S1 through 9.18.39-S1, and 9.20.9-S1 through 9.20.13-S1.

CVSS 3.1 · 7.5 High EPSS 11.3% KEV · Not listed
Vendors
Isc
Products
CVE-2025-40776

Birthday Attack against Resolvers supporting ECS

A `named` caching resolver that is configured to send ECS (EDNS Client Subnet) options may be vulnerable to a cache-poisoning attack. This issue affects BIND 9 versions 9.11.3-S1 through 9.16.50-S1, 9.18.11-S1 through 9.18.37-S1, and 9.20.9-S1 through 9.20.10-S1.

CVSS 3.1 · 8.6 High EPSS < 1% KEV · Not listed
Vendors
Isc
Products
CVE-2024-1737

BIND's database will be slow if a very large number of RRs exist at the same name

Resolver caches and authoritative zone databases that hold significant numbers of RRs for the same hostname (of any RTYPE) can suffer from degraded performance as content is being added or updated, and also when handling client queries for this name. This issue affects BIND 9 versions 9.11.0 through 9.11.37, 9.16.0 through 9.16.50, 9.18.0 through 9.18.27, 9.19.0 through 9.19.24, 9.11.4-S1 through 9.11.37-S1, 9.16.8-S1 through 9.16.50-S1, and 9.18.11-S1 through 9.18.27-S1.

CVSS 3.1 · 7.5 High EPSS 2.1% KEV · Not listed
Vendors
Products
CVE-2023-50868

bind9: Preparing an NSEC3 closest encloser proof can exhaust CPU resources

The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

CVSS 3.1 · 7.5 High EPSS 74.3% KEV · Not listed
Vendors
Debian Fedoraproject Isc and 3 more
Products
Debian Linux Fedora Bind and 16 more
CVE-2023-3341

A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly

The code that processes control channel messages sent to `named` calls certain functions recursively during packet parsing. Recursion depth is only limited by the maximum accepted packet size; depending on the environment, this may cause the packet-parsing code to run out of available stack memory, causing `named` to terminate unexpectedly. Since each incoming control channel message is fully parsed before its contents are authenticated, exploiting this flaw does not require the attacker to hold a valid RNDC key; only network access to the control channel's configured TCP port is necessary. This issue affects BIND 9 versions 9.2.0 through 9.16.43, 9.18.0 through 9.18.18, 9.19.0 through 9.19.16, 9.9.3-S1 through 9.16.43-S1, and 9.18.0-S1 through 9.18.18-S1.

CVSS 3.1 · 7.5 High EPSS 2.9% KEV · Not listed
Vendors
Debian Fedoraproject Isc and 1 more
Products
Debian Linux Fedora Bind and 6 more
CVE-2023-50387

bind9: KeyTrap - Extreme CPU consumption in DNSSEC validator

Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

CVSS 3.1 · 7.5 High EPSS 100.0% KEV · Not listed
Vendors
Products
CVE-2022-2906

Memory leaks in code handling Diffie-Hellman key exchange via TKEY RRs (OpenSSL 3.0.0+ only)

An attacker can leverage this flaw to gradually erode available memory to the point where named crashes for lack of resources. Upon restart the attacker would have to begin again, but nevertheless there is the potential to deny service.

CVSS 3.1 · 7.5 High EPSS 2.0% KEV · Not listed
Vendors
Isc
Products
CVE-2022-2881

Buffer overread in statistics channel code

The underlying bug might cause read past end of the buffer and either read memory it should not read, or crash the process.

CVSS 3.1 · 5.5 Medium EPSS 1.4% KEV · Not listed
Vendors
Isc
Products
CVE-2016-9444

bind: assertion failure while handling an unusually-formed DS record response

named in ISC BIND 9.x before 9.9.9-P5, 9.10.x before 9.10.4-P5, and 9.11.x before 9.11.0-P2 allows remote attackers to cause a denial of service (assertion failure and daemon exit) via a crafted DS resource record in an answer.

CVSS 3.0 · 7.5 High EPSS 18.1% KEV · Not listed
Vendors
CVE-2016-9147

bind: assertion failure while handling a query response containing inconsistent DNSSEC information

named in ISC BIND 9.9.9-P4, 9.9.9-S6, 9.10.4-P4, and 9.11.0-P1 allows remote attackers to cause a denial of service (assertion failure and daemon exit) via a response containing an inconsistency among the DNSSEC-related RRsets.

CVSS 3.0 · 7.5 High EPSS 24.6% KEV · Not listed
Vendors
Products
CVE-2016-9131

bind: assertion failure while processing response to an ANY query

named in ISC BIND 9.x before 9.9.9-P5, 9.10.x before 9.10.4-P5, and 9.11.x before 9.11.0-P2 allows remote attackers to cause a denial of service (assertion failure and daemon exit) via a malformed response to an RTYPE ANY query.

CVSS 3.1 · 7.5 High EPSS 40.6% KEV · Not listed
Vendors
Debian Isc Netapp and 1 more
Products
CVE-2016-6170

bind: Improper restriction of zone size limit

ISC BIND through 9.9.9-P1, 9.10.x through 9.10.4-P1, and 9.11.x through 9.11.0b1 allows primary DNS servers to cause a denial of service (secondary DNS server crash) via a large AXFR response, and possibly allows IXFR servers to cause a denial of service (IXFR client crash) via a large IXFR response and allows remote authenticated users to cause a denial of service (primary DNS server crash) via a large UPDATE message.

CVSS 3.1 · 6.5 Medium EPSS 40.9% KEV · Not listed
Vendors
CVE-2014-3214

bind: assertion failure when using prefetch

The prefetch implementation in named in ISC BIND 9.10.0, when a recursive nameserver is enabled, allows remote attackers to cause a denial of service (REQUIRE assertion failure and daemon exit) via a DNS query that triggers a response with unspecified attributes.

CVSS 2.0 · 5.0 Medium EPSS 17.3% KEV · Not listed
Vendors
Isc
Products
CVE-2016-8864

bind: assertion failure while handling responses containing a DNAME answer

named in ISC BIND 9.x before 9.9.9-P4, 9.10.x before 9.10.4-P4, and 9.11.x before 9.11.0-P1 allows remote attackers to cause a denial of service (assertion failure and daemon exit) via a DNAME record in the answer section of a response to a recursive query, related to db.c and resolver.c.

CVSS 3.1 · 7.5 High EPSS 38.7% KEV · Not listed
Vendors
Debian Isc Netapp and 1 more
Products
CVE-2014-3859

bind: assertion failure during EDNS option processing

libdns in ISC BIND 9.10.0 before P2 does not properly handle EDNS options, which allows remote attackers to cause a denial of service (REQUIRE assertion failure and daemon exit) via a crafted packet, as demonstrated by an attack against named, dig, or delv.

CVSS 2.0 · 5.0 Medium EPSS 7.0% KEV · Not listed
Vendors
Isc
Products
CVE-2015-8705

bind: crash when converting OPT resource records and ECS options to text format

buffer.c in named in ISC BIND 9.10.x before 9.10.3-P3, when debug logging is enabled, allows remote attackers to cause a denial of service (REQUIRE assertion failure and daemon exit, or daemon crash) or possibly have unspecified other impact via (1) OPT data or (2) an ECS option.

CVSS 3.0 · 7.0 High EPSS 7.9% KEV · Not listed
Vendors
Isc
Products
CVE-2014-8500

bind: delegation handling denial of service

ISC BIND 9.0.x through 9.8.x, 9.9.0 through 9.9.6, and 9.10.0 through 9.10.1 does not limit delegation chaining, which allows remote attackers to cause a denial of service (memory consumption and named crash) via a large or infinite number of referrals.

CVSS 2.0 · 7.8 High EPSS 59.0% KEV · Not listed
Vendors
CVE-2014-8680

bind: flaws in GeoIP leading to a denial of service

The GeoIP functionality in ISC BIND 9.10.0 through 9.10.1 allows remote attackers to cause a denial of service (assertion failure and named exit) via vectors related to (1) the lack of GeoIP databases for both IPv4 and IPv6, or (2) IPv6 support with certain options.

CVSS 2.0 · 5.4 Medium EPSS 9.0% KEV · Not listed
Vendors
Isc
Products
CVE-2015-1349

bind: issue in trust anchor management can cause named to crash

named in ISC BIND 9.7.0 through 9.9.6 before 9.9.6-P2 and 9.10.x before 9.10.1-P2, when DNSSEC validation and the managed-keys feature are enabled, allows remote attackers to cause a denial of service (assertion failure and daemon exit, or daemon crash) by triggering an incorrect trust-anchor management scenario in which no key is ready for use.

CVSS 2.0 · 5.4 Medium EPSS 22.9% KEV · Not listed
Vendors